R

패키지 library 관련해서 질문드립니다

1
패키지 설치를 하고 library로 불러오면 중간에 저렇게 계속 오류가 납니다. 온라인 강의라서 교수가 제대로 된 설명도 안해주고 오류가 나면 그냥 여러분이 알아서 해결하셔야 합니다. 좋은 프로그램을 쓰면서 무료다 보니 어쩔 수 없..

패키지 설치를 하고 library로 불러오면 중간에 저렇게 계속 오류가 납니다. 온라인 강의라서 교수가 제대로 된 설명도 안해주고 오류가 나면 그냥 여러분이 알아서 해결하셔야 합니다. 좋은 프로그램을 쓰면서 무료다 보니 어쩔 수 없다라는 말밖에 안하네요ㅠㅠ 이거 어떻게 해결하나요?

sd 2022-05-15
sd 님께서 2022-05-15에 R에 올린 질문

댓글

1개의 답변

1
여러가지 원인이 있을 수 있겠습니다만 패키지 설치 후 에러가 발생한다고 하는 걸로 봐서 설치하신 패키지와 R 버전이 맞지 않아서 발생하는 에러일 수 있습니다. 설치하신 패키지에서 지원하는 R 버전이 무엇인지 확인해보..

여러가지 원인이 있을 수 있겠습니다만

패키지 설치 후 에러가 발생한다고 하는 걸로 봐서

설치하신 패키지와 R 버전이 맞지 않아서 발생하는 에러일 수 있습니다.

설치하신 패키지에서 지원하는 R 버전이 무엇인지 확인해보시기 바랍니다.

피토니 2022-05-15
사탕 주기
피토니 님께서 2022-05-15에 R에 올린 글
보관하기
1
 
sd 2022-05-15
R은 최신버전이고 패키지들도 다 지원하는데 왜 나는지 모르겠네요 ㅠㅠ
1
 
피토니 2022-05-15
R 버전과 패키지 이름하고 버전이 어떻게 되실까요?
1
 
sd 2022-05-15
R 은 4.2.0이고 패키들은 (GISTools,ggplot2,sp,maptools,rgeos,rgdal,foreign,xlsx,raster,sf,readxl,data. table,RColorbrewer,dplyr) 이거를 저희 수업에서 설치해서 쓰는데 패키지 설치를 하고 library로 컨트롤 엔터로 불러오는 과정에서 중간에 자꾸 세션이 종료됩니다 ㅠㅠ
1
 
피토니 2022-05-17
역시나 버전 호환 문제인 것 같습니다. dplyr 패키지를 삭제하신 후 install.packages("dplyr",dependencies=TRUE) 명령으로 다시 설치해보시기 바랍니다.
1
 
sd 2022-05-17
넵 감사합니다!
1
 
sd 2022-05-17
삭제했다가 명령어로 깔아도 세션이 자꾸 종료되네요 ㅠㅠ
1
 
sd 2022-05-17
아니면 패키지들 다 삭제했다가
저 명령어로 다시 깔아볼까요?

댓글

조회수 676
답글 1
URL